Laser-software

Fra Bitraf
Hopp til navigering Hopp til søk

Software

AutoLaser 2.0.8

Fulgte med maskinen og er det vi bruker til å kjøre jobben. Dette er et (meget) enkelt program som lar deg eksportere filer i .OUT formatet som X700-laseren bruker. Det finnes en User's Manual for AutoLaser Software (pdf). Maskinen kan i teorien importere Illustrator vektor-format, men dette krasjer uansett hvilken variant man bruker. DXF fungerer imidlertid bra. Det samme gjør bitmap-formatene som er støttet (PNG, BMP, JPG).

Autolaser kjører i Wine og kan lastes ned herfra: http://www.topwisdom.com.cn/en/down.asp

Troubleshooting for autolaser: "Unit near": smelter sammen punkter, fint hvis laseren ikke kjører i sammenhengende baner.

AutoLaser versjoner

2019-08-12 
nyeste versjon til nedlasting er AutoLaser V2.4.8
AutoLaser 2.3.4 er installert på Laser PC.

Inkscape

Inkscape fungerer bra sammen med Autolaser, men krever noen forhåndsregler.

  • Alle objekter må være stier (paths). Du kan velge Path -> Object to Path for å gjøre dette med tekst, mv.
  • Tekst: skriv tekst, velg teksten, gjør først Path, "Object to path", deretter Path, "Combine"

.DXF-eksport

  • Forskjellige farger på stiene i Inkscape blir tolket som lag (layers) i AutoLaser.
  • Velg mm og LWPOLYLINES. Uten polylines blir ikke splines eksportert og du får "hakkete" kanter.

For å benytte funksjonen Carve i Autolaser må du ha sammenhengende polygoner. DXF-eksport fra Inkscape gir ikke dette og hver enkelt spline er separat. Du kan derfor merke alle objekter i Autolaser og velge "Unit near" for å slå sammen flere splines til sammenhengende polygoner. Detta fungerar dock inte alltid, bruk då istællet .PLT formatet.

Dersom du har problemet med at tekst får ekstra linjer, forsøk å eksporter uten LWPOLYLINES opsjonen eller bruk .PLT formatet nedan.

.PLT-eksport

  • Forskjellige farger på stiene i Inkscape blir slått sammen till ett lag i AutoLaser.
  • Detta format støtter export av sammanhengende polygoner och ær meget lempligt att anvændas till designs som skall Carve:s.

Fusion 360

Fusion 360 er gratis for hobbybrukere. Installer trial-versjon, og når den går ut velger du den modellen.

Du kan eksportere sketch til DXF i Fusion 360 ved å høyreklikke sketchen og velge Save as DXF.

FreeCAD

Dersom du tegner objektet ditt i 3d, kan du bruke Part -> Cross Sections til å hente ut 2d tverrsnitt. Om det du tegner er 2d (Sketch/Draft) så trengs ikke dette steget. Vektorene må ligge i XY-planet for å bli forstått korrekt av laseren. Du kan deretter eksportere til 'Autodesk DXF'.

Desverre så forstår ikke AutoLaser denne DXF eksporten direkte (FreeCAD 0.15). En løsning er å åpne filen i QCad (også gratis) og lagre som "R15 DXF drawing".

Adobe Illustrator

Sett dokumentet til mm i File->Document setup

Tekst med muligheter for f.eks. å kunne fylle tekst (raster). Meny: Object -> Compund Path -> Release

Eksporter som DXF-fil "file>export>export as" med følgende innstillinger: Autocad Version: R14/LT98/LT97 Scale 1 mm = 1 Unit

Importer i Autolaser som Metric: (1 unit = 1 mm)

Tips: DXF filene støtter farger på linjene, så når du definerer disse i Illustrator, kommer de med i Autolaser. "export selection" støtter ikke DXF.

DXF import i Autolaser kan av og til ha problemer med grupperte objekter. Her er et javascript som enkelt løser ut alle grupperinger i dokumentet https://forums.adobe.com/thread/456042 Last ned scripet og kjør det fra: File->Scripts->Other Scripts..

Sketchup

TODO: dokumenter hvordan eksportere! og evt tips&triks

Torbjørns råd: IKKE BRUK SKETCHUP fordi den ikke har kurver.

OpenSCAD

Lag en 2d-modell, trykk F6 for å rendre og lagre den med File | Export | Export as DXF